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1 General descriptions 
 
The STIM202 evaluation kits provide measurement and configuration access to STIM202 multi-axis gyro modules. 
Gyro module configuration, graphical result presentation and save data to file functions are supported. The single 
voltage supply required for operation is provided from any PC or laptop USB port.  
 
Two alternative evaluation kits are available, for either PCI or USB connectivity. 
 

1. STIM202 EVK PCI 
The evaluation kit with PCI connectivity is the recommended solution for thorough characterization. The kit is 
in the following referred to as "the PCI kit" 

 
Figure 1: STIM202 EVK PCI 

 
 

2. STIM202 EVK USB 
The evaluation kit with USB connectivity provides the alternative solution, e.g. for smaller, portable laptop 
setups, and is an excellent choice for gyro module configuration and shorter measurement series. The kit is in 
the following referred to as "the USB kit" 

 
Figure 2: STIM202 EVK USB 

 
 
Note that the evaluation kits does not include the gyro module. 
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2 Kit contents 
 

 STIM202 communication and power cable 

 Either of the two options for interface hardware; 
o PCI to RS422 interface card,  "the PCI card", for the PCI kit, supporting all gyro module transmission 

bit rates (377400, 460800 and 921600 bits/s) 
o USB to RS422 interface cable,  "the USB cable", for the USB kit, supporting only the default gyro 

module transmission bit rate (460800 bits/s) 

 Memory stick with PC software and User manual 

 Torx screw driver for fixing connector of communication and power cable to gyro module 

 Hard copy of User manual 
 

3 Kit Features 
 

 PCI or USB connectivity to PCs/ laptops 

 Up to 1000Hz sampling rate 

 Temperature measurements 

 Service mode access 
o Full gyro module information 
o Full gyro module configuration capability 
o Detailed gyro module diagnostics 
o Help section 

 Measure panel 
o Data presentations and save data to file capability 
o Custom scale and zoom functions 
o CRC check 

 Logging panel 
o Support for any measurement duration (only limited by HD memory and processor capacity of PC) 
o Various stop criteria for measurement series (Manually, No of samples or Time elapsed) 

 Measurements on 2 gyro modules simultaneously supported (requires either one or two additional cables 
depending on the kit in use)  

 

4 Configurable and readable parameters 
 
In addition to measurements, the evaluation kits provide access to the following gyro module user configurable 
parameters:  
 

 Output format (angular rate, increment angle, etc.) 

 Datagram format (standard, extended, etc.) 

 Sampling rate (125 samples/s, 250 samples/s, etc.)  

 Bandwidth/ Low pass filter frequency (16Hz, 33Hz, etc.)  

 RS422 transmission bit rate (374400 bits/s, 460800 bits/s, etc.) 

 Number of stop bits in datagram (1 or 2 stop bits) 

 Parity bit (no parity, odd parity, even parity) 

 Line/ Datagram termination (on/off, None/ <CR><LF>) 
 
 
The evaluation kits provide access to the following user readable gyro module parameters:  
 

 Unit part number  

 Serial number 

 Firmware revision  

 Hardware revision  

 Guro module diagonistics 
 
Gyro module diagnostic information includes RAM and flash checks, stack handling checks, status of internal voltage 
supply references, and various parameter reports for each measurement axis. 
 
Note: External trigger functionality of STIM202 are not supported by the evaluation kits. 
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5 System requirements 
 

 Windows XP SP2 (or later), Windows Vista, Windows 7 (32/ 64bit) 

 1 free USB port and 1 free PCI slot for the PCI kit 

 2 free USB ports for the USB kit 

 Quad core processor recommended (when simultaneously logging data from two gyro modules) 
 
 
6 Getting started 
 
Two separate software installations are required: 
 

 NI serial driver installation 

 PC software installation 
 
6.1 Installation of NI serial driver 
 
Install the National Instruments (NI) serial driver from the CD-ROM included in the kit. This process is self-instructive. 
Follow the on-screen messages without doing any configuration changes. 
 
Figure 3 and Figure 4 show two of the messages that appear during serial driver installation. 
 
The NI serial driver can also be found from the Sensonor support site. Use this site to regularly check for updates. 
 

 

 
Figure 3: NI serial driver installation. Start Installation 

 

http://www.sensonor.com/help-menu/support.aspx
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Figure 4: NI serial driver installation. Installation complete 

 
 
6.2 Installation of PC software 
 
Install the PC software by running "setup.exe" found on the included memory-stick. Follow the on-screen instructions 
to complete the installation. See Figure 5 through Figure 10 for guidance. 
 
The PC software can also be downloaded from the Sensonor support site. Use this site regularly to check for updates. 

 

 
Figure 5: PC software installation (1 of 6). Installer initialization 

 

http://www.sensonor.com/help-menu/support.aspx
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Figure 6: PC software installation (2 of 6) 

 

 
Figure 7: PC software installation (3 of 6) 
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Figure 8: PC software installation (4 of 6) 

 

 
Figure 9: PC software installation (5 of 6) 
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Figure 10: PC software installation (6 of 6). Installation complete 

 
 
6.3 First hardware connections 

6.3.1 Common preparations 

 
1. Connect a gyro module to the Micro-D connector of the STIM202 communication and power cable. Use the T6 

Screw driver (included) for tightening the fixing screws of the connector to gyro module 

6.3.2 For preparing the PCI kit (skip this step if the USB kit is used) 

 
2. Install the PCI card into a free PCI slot of the PC cabinett 

 
3. Connect the 9 pin D-SUB connector of the STIM202 communication and power cable to either PORT 1 or 

PORT 2 of the PCI card. Tighten the screws of the D-SUB connector to ensure a good electrical connection 

6.3.3 For preparing the USB kit (skip this step if the PCI kit is used) 

 
2. Connect the 9 pin D-SUB connector of the STIM202 communication and power cable to the USB cable. 

Tighten the screws of the STIM202 communication and power cable to ensure a good electrical connection. 
See Figure 2 to identify two cables if necessary. (The USB cable is the black one with blue connectors.) 
 

3. Connect the (blue) USB connector of the USB cable into a free USB port of the laptop/ PC 
 

6.3.4 Common verifications 

 
4. Verify that the NI serial driver installation has completed successfully in the Device Manager. See Control 

Panel -> Hardware and Sound, or similar path, to locate this. An example for Device Manager in Windows 7 is 
shown in Figure 11 
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5. Notice the assigned COM port(s) as this information is needed later for connecting to gyro module(s) from PC 

software 
 

 
Figure 11: COM port assignments for PCI card and USB cable in Windows 7 
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6.4 First PC software start-up 
 

1. Navigate to the ‘Sensonor evaluation tools’ folder from Windows start menu. Click on the shortcut named 
"STIM202 EVK" to start the PC software. Ensure to run program as administrator (as this is needed for full 
function) 
 

 
Figure 12: Starting PC software from Windows 7 start menu 

 
2. A pop-up box for software registration appears. Fill in four open fields and click "Submit". The default email 

client opens. Press "Send" in order to complete this step (and the user information is sent back to Sensonor) 
 

 
Figure 13: Welcome message and software registration 
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3. A pop-up box appears, asking for a parameter (.INI) file. Select the INI-file available in the installation folder 
and click "Load" 
 

 
Figure 14: INI-file selection 

 
4. The Normal mode panel is shown 

 

 
Figure 15: Normal mode panel after selecting INI-file 
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5. Verify the correct COM port settings in the Parameters view. Password to edit is ‘stim’. Click "OK" to confirm 
when the correct COM port(s) is (are) selected 
 

 
Figure 16: Editing the INI-file in order to verify the correct COM port settings 

 
6. Establish connection to module by clicking the ‘Connect to HW’ button in Normal mode panel. A green LED light 

appears, indicating that the COM port(s) is (are) opened 
 

 
Figure 17: Normal mode panel after first hardware connection 
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7. Change the ’Apply voltage’ control switch position to ’On’. The pop-up message telling "Turn on device supply 
voltage" appears. Do this by inserting the USB connector of the STIM202 communication and power cable into 
a free USB port of the PC/ laptop. Confirm the supply voltage applied by clicking ‘OK’ on the pop-up message 
 

 
Figure 18: Normal mode panel when USB connector of STIM202 communication and power cable is to be inserted 

 
8. Verify the connection to module by clicking on the ‘Request config DG’ button. An example of such a result is 

shown in Figure 19. (The kit is now ready for use !) 
 

 
Figure 19: Result of sending ’Request config DG’ to the gyro module 
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7 Introduction to PC software 
 
7.1 Panels overview 
In addition to the panel already shown (Normal mode and Parameters panel), other panels are also available: 
 

 
Figure 20: Service mode panel 

 

 
Figure 21: Measure panel 
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Figure 22: Logging panel (for saving data to file) 

 
 
7.2 Main panel menus 
 

Menu Description 

‘File’ → ‘New parameter file’ For creating a new INI-file. Notice that this new INI-file also needs be edited by 
the user before taken into use. The content is not equal to any existing INI-files. 
Notice also that the Parameters view in the software is not updated with the new 
INI-file content until the user clicks the "Edit" button (this triggers an update of this 
view) 

‘File’ → ‘Open parameter file’ For opening and taking a specific INI-file into use 

‘File’ → ‘Save parameter file as’ To save parameters into an INI-file 

‘File’ → ‘Print parameters’ For printing the current ‘Parameters’ content at the default printer 

‘File’ → ‘Edit parameters’ To edit the ‘Parameters’ content 

‘File’ → ‘Exit’ To exit program 

‘Help’ → ‘Check for updates’ Opens the Sensonor support site in a web browser. NI serial drivers, any PC 
software updates and new releases of User manuals can be obtained from here  

‘Help’ → ‘About’ About the program (Program name, publisher and software revision number) 

 

 
Figure 23: File Menu 

 
Figure 24: Help menu 
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7.3 Normal mode panel descriptions 
 
Table 1: Normal mode panel descriptions 

Panel unit Functionality and description 

Connect to HW To connect to interface hardware. Opens PC COM port according to selections in 
active parameter file 

LED Indicator for hardware connection. A GREEN light indicates the corresponding COM 
port is opened 

Disconnect from HW To Disconnect from interface hardware. Closes the corresponding COM port 

Apply voltage switch (On/Off) To be switched manually (ON or OFF) by user when asked to. Controls certain 
functions of the PC software  

Device box Should hold the correct gyro module (device) number according to active parameter 
file. Choice depends on which gyro module and COM port the user wants to operate 

Reset device button Resets the gyro module. Sends reset command (‘R’) 

Request config DG button Sends command (‘C’) to receive configuration datagram 

Request identity DG button Sends command (‘N’) to receive part number datagram 

Request serial# DG button Sends command (‘I’) to receive serial number datagram 

Response window Lists responses from the gyro module 

 
 
7.4 Service mode panel descriptions 
 
Service mode is used for gyro module configuration. 
 
Service mode is entered by clicking on the Service mode tab next to the Normal mode tab. Panel units, functionalities 
and descriptions are listed in Table 2. Exit from gyro module Service mode to Normal mode is done by pressing one of 
the other panel tabs (Normal, Logging, Service or Parameter panel tab). 
 
Note: Changes made for the gyro module in Service mode are only stored permanently in gyro module flash memory 
when the save command (‘s’) is issued. 
 
Table 2: Service mode panel descriptions 

Panel unit Functionality and description 

Available commands window Shows a list of available commands. See product datasheet for details 

Complete command window Contains the complete command to send. It is auto-completed by usage of the 
listings in the available commands window. Left click in the complete command 
window shows a list of earlier sent commands. Right click enables manual command 
entry 

Send command button Sends command to the gyro module 

Active device indicator Informs about the active gyro module (device). Corresponding COM port is according 
to the active parameter file 

Command response window Shows the responses from the gyro module. See product datasheet for details 

Erase button Erases the content of the command response window 

Save button Saves the content of the command response window to a text file with a detailed 
date and time tag 
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7.5 Measure panel descriptions 
 

Table 3: Measure panel descriptions 

Panel unit Functionality and description 

Measure button Starts a measurement series 

Samples box Defines the number of samples to be collected (max 50 millions) 

Save to file button Saves data from a completed measurement series to a result file. The file path 
defined in the active parameter file is proposed 

X-, Y- and Z-axis check boxes Selects which axis data to present in the graph area (up to 3 axes can be plotted) 

Active device indicator Informs about the active gyro module (device). Corresponding COM port is according 
to the active parameter file 

CRC and DG-ID LEDS Confirms all CRC checks and DG-IDs as expected. Normally GREEN. LEDs turn 
RED if checks fail 

Data box Selects which datagram content to be shown. Several options are available, 
depending on the active datagram type. Use the arrows in the left side of box to 
scroll between available selections. The plot updates immediately if a measurement 
series has already been done. 

Scale box Enables user to select between different scales (Full range, User defined, or Auto) 

Sample rate box Informs what sample rate has been used for the measurements 

Unit box Indicated the active Output unit (Angular Rate, Incremental Angle, etc.) 

DG type box Shows the type of datagram received 

Save to disk icon Saves a picture of the plotted data to file 

Print icon Prints a picture of the plotted data to the default printer 

1:1 icon Resets zoom level to 1:1 (if ZOOM is active. See below) 

Zoom icon Enables a custom zoom of the presented results in the strip chart (graph area) 
according to placement of available cursors 

Cursors (On/Off) switch Enables usage of cursors (default is Off) 

Cursor 1 Shows the location of cursor no 1 

Cursor 2 Shows the location of cursor no 1 

Delta Shows the delta between the two cursor locations (X and Y values) 

Progress bar A blue continuous line shows the measurement series progress 

Lower bar on panel Shows the INI-file in use and the active mode (NORMAL MODE) 

 
Save data to file from measure panel: 
An example of a result file is shown in Figure 25, for a standard datagram measurement series of device # 1. A 
description of each of its column of data is found in Table 4. 
 

 
Figure 25: Result file example 

 
Table 4: Result file example. (Standard datagram content written to file.) 

DG-type Col. # Heading Comments 

S
ta

n
d
a
rd

 

 

1 Time[s] Time in seconds  

2 GYRO_X Gyro signal X-axis 

3 GYRO_Y Gyro signal Y-axis 

4 GYRO_Z Gyro signal Z-axis 

5 STS Status-byte 

6 RxCRC Received CRC 

7 CalcCRC Calculated CRC 

8 DG_ID Datagram identifier 
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7.6 Logging panel descriptions 
 
Table 5: Logging panel descriptions 

Panel unit Functionality and description 

Start button Starts data logging 

Stop button Stops data logging 

Stop criteria slide User selections between “manually”, “no of samples” and “Time 
elapsed” for stopping a measurement series 

Samples box In use when defining a series length with “no of samples” 

Time elapsed Shows the real time for the test running 

Samples acq. Shows number of samples acquired 

CRC_errors Shows number of CRC errors (normally 0, otherwise the user should 
consider to reject results data in any analysis) 

Resynch’s Increments from 0 to a number if any re-synchronisations are needed in 
order to re-establish data collections from module 

 
Log to file capability: 
 

 Quad core processor is recommended when measuring on two gyro modules simultaneously  

 The size of the log file is only limited by the free memory of the hard disk(s) in use 

 The path for result file storage is defined in the active parameter file 

 The program should be run as administrator to ensure the necessary rights to establish result files 
 
7.7 Parameters panel descriptions 
 
Table 6: Parameters panel descriptions 

Panel unit Functionality and description 

===== General parameters =====  

Password Current valid password to be able to edit the parameters list. The 
password is “stim” 

Folder for result-file storage “c:\userdata\test\ 

What priority will this program run with Instructs the program priority for the PC operation system 

What format to use for result files ASCII text by default. Can be changed to 8 byte binary 

===== Device communication ===== 
IMPORTANT MESSAGE: Always verify 
hardware connections and COM port settings 
before trying to connect to the device 

 

RS422 port # to device 1 Defining which COM port # to be assigned to gyro module (device) # 
1 

RS422 port # to device 2 Defining which COM port # to be assigned to gyro module (device) # 
2 

RS422 Bitrate [bit/s] Manual RS422 bit rate selection. NOTE that USB cable that comes 
with the USB kit, supports only the default 460800 bits/s option, while 
the PCI card of the PCI kit supports all available bit rates 

RS422 Stopbit 1 or 2. Default is “1” 

RS422 parity None, odd or even. Default is “None” 

===== External Hardware =====  

The GPIB-card #  to use Normally "0" (when no GPIB card in user). If card(s) are in use; the 
first card will be assigned to #1, second to #2, etc. Default value is 
“0” 

Type of power supply used Normally "None" (when not in use). Agilent E3631A, E3633A and 
E3644A supported. Default value is “None” 

Interface that the power is connected with Normally "None" (when not in use). RS232 (for Agilent E3631A only) 
and GPIB supported. Default is “None” 

Port or address to power Normally "0", when not in use. Selectable up to 31. Default is “0” 

Voltage on output of power supply [V] Default value is “5.1”. Can be neglected if not in use. Value should 
be within the supply voltage range of the gyro module. Clicking on 
the arrow of the control unit when editing this parameter allows for 
voltages as high as 6.0V maximum. Manual entry allows even higher 
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values, however with a warning. Note: The entered value/ voltage 
applied to the gyro module should never exceed the absolute 
maximum ratings value for the supply voltage of the gyro module 
(maximum 7.0V) 

Current limit on output of power [A] Default value is “1.0”. To limit the current consumption from the 
power source 

 
7.8 Messages from the program 
 
Messages that the program can display are listed in Table 7: 

 
Table 7: Possible messages given by the program 

# Message Description 

1  This application is already running! 
Stop loading of 2. instance... 

The program is already started, a second instance will 
not be allowed 

2  Wrong password entered! The password entered does not match the required one 
for this INI-file 

3  No response to message was received Did not receive the expected response to sent service-
mode command 

4  There is no measurement data available for storage To be able to save measurement data, there must be 
data available 

5  Unable to open the selected file Saving of measurement data failed, unable to open or 
create the selected file 

6  Unable to allocate the required memory Failed to acquire the requested number of datagrams 
from the gyro module due to error when trying to allocate 
memory for temporary storage 

7  No product identification datagram received Even after retries the, expected datagram is not received 
as response to command sent  

8  No configuration datagram received Even after retries the, expected datagram is not received 
as response to command sent 

9  No serial number datagram received Even after reties the, expected datagram is not received 
as response to command sent 

10 No datagrams received Failed to acquire the requested number of datagrams 
from the gyro module, no recognizable datagrams 
received 

11 Turn off device supply voltage Instruction to user when running without controlled 
power-supply 

12 Turn on device supply voltage Instruction to user when running without controlled 
power-supply 

13 Error encountered when trying to control voltage Failed to control the specified power-supply 

14 Unexpected DG-ID received ! When waiting for datagrams, unexpected datagrams are 
received 

15 Unable to read config DG to determine output unit ! Unable to read configuration datagram to determine the 
output unit 

16 Unable to synch with DG-stream ! Failed to acquire the requested number of datagrams 
from the gyro module, unable to get in synch with 
datagram stream 

17 Error encountered when trying to print, check 
configuration ! 

Failed to print the graph, check that a printer is 
configured 

18 Unable to create result-folder specified by parameter ! The specified pathname can not be created, either due 



 

USER MANUAL EvaluationTool 
STIM202 Evaluation Kit 

 

DOK333 rev.05                                                                    20/20                                                              Jan 2012 
 

to access-rights or errors in the path specification 

19 Unable to enter service-mode ! Unable to enter service-mode, does not receive 
expected response to command. 

20 Unable to save parameters to active INI-file ! Error encountered when trying to save parameters onto 
INI-file 

21 Edit-mode of parameters is active, unable to exit ! The edit-mode of parameters are active, unable to exit 
the program until edit mode is ended 

22 You are about to change the RS422 bit rate.  
If are you using the USB kit hardware provided by 
Sensonor, please notice that you will not be able to 
communicate with the device if you change to 
something else than supported 460800 b/s!  
For the PCI card there are no worries - it supports all 
available bit rates 

A warning to the user about limitations for certain RS422 
hardware 

23 Unable to create/save to selected file, check access 
rights to folder 

Unable to open or create the specified file in the 
selected folder, try another filename and/or location. The 
reason may be lacking access rights to the folder, or 
illegal filename format 

24 Unsupported datagram-type received When trying to read datagrams from the device an 
unsupported datagram-id was encountered. 

 


